Change Host Resource Utilization

Anyone know how I can change my CPU resource allocation, for some reason it is showing as -3MHz reserved. Initially I run setup script and made a mistake & entered 3 for CPU allocation (was thinking 3 GHz) I ran script again and set it to 3000 MHz but seems to be stuck at 3?

image

perhaps this:

Item 4 from the Instructions:

Via manual clone of the repository
4. generate device metadata and nomad client configuration.Then it install nomad configuration on the system. This option can also be used to update allocated compute resources and payment identity after first initialization.

bash onboarding.sh config

ok so not sure what is going on but here in the /etc/nunet/client.json my cpu allocation is set to -3000 pretty sure I set it at 3000 the 2nd go around when running “bash onboarding.sh config” perhaps I slipped and hit the - key at some point.

anyway variables etc are stored here /etc/nunet/client.json

so i simply changed the section "reserved": {"cpu": -3000, "memory": 0}}} to "reserved": {"cpu": 0, "memory": 0}}}

then I restarted the service using systemctl sudo systemctl restart nomad-client.service

all is looking good, also it appears entering 0 removes all limits and allows 100% utilization.

Thanks, I think that did update it but needed to restart docker container etc using the service the script installed :slight_smile:

that’s great. cheers! :slight_smile: